popo factory blog

Flash Player 9.0.124.0のセキュリティレベルが変わった件(要確認)

   

2008年4月8日のFlash Playerのバージョンアップによりセキュリティレベルが変わったようです。

http://www.adobe.com/support/security/bulletins/apsb08-11.html

Flashの9.0.124.0からHTMLタグにallowScriptAccessの記述をいれないと、場合によって
getURL(),navigateToURL()が動作しなくなります。

objectタグの場合
param name=”allowScriptAccess” value=”always”

embedタグの場合
allowScriptAccess=always

※例としてalwaysを指定していますが、セキュリティレベルによってsamedomainなど
書き換えて使用ください。

Flashを使用したサイトでクリック数などが急に下がってきている場合は
確認してみた方がいいかもしれません。

 - ActionScript, Flash